


Curriculum Plan of Mathematics STD VIII (Session: 2025-26)
Book prescribed: NCERT Mathematics

Month Project/Activity Mental Maths / Written Work
Content/Theme Value based
questions

April » Evolution of number system (Natural » Worksheet > Key Terms
Chapter 1 (Rational Numbers) numbers, Whole numbers, Integers) which | > Discussionon |» NCERT

» Rational numbers lead us to the collection of Rational Real life Textbook

» Properties of rational numbers numbers. applications of Exercise

» Roles of zero and one Rational » Assignment

» Negative of a rational number number. » R.D Sharma

» Multiplicative inverse

» Representation of rational numbers on number line.

> Rational numbers between two rational numbers

Chapter 2 (Linear equations in one variable)
» Solving equations having variable on one side
» Application of linear equations
» Solving equations having variable on both side
» Reducing equation to simpler form
» Equations reducible to the linear form

» Solving a linear equation in one
variable — balancing method

» Quiz cum Sport activity on linear
equation and its application

» Worksheet

» Formation of
equation based
of real life
application of
linear equation

» Value based
questions.

vV VvV

Reference book

Key Terms
NCERT
Textbook
Exercise
Assignment
R.D Sharma
Reference book




Month Project/Activity Mental Maths / | Written Work
Content/Theme Value based
questions

June = Convex and concave polygon » Worksheet » Key Terms
Chapter 3 (Understanding Quadrilaterals) = Angles in a polygon » Relating » NCERT

» Polygons = Exterior angles of a polygon different » Textbook

» Classification of polygons = Properties of the diagonals of a rhombus shapes that are Exercise

» Diagonals = How to change one Quadrilateral to another used in » Assignment

» Convex and Concave Polygons = Paper folding and cutting activity to understand properties everyday life. | > R.D Sharma

» Regular and irregular polygons

» Interior Angle sum property for polygons

» Sum of measure of exterior angle of a
polygon

» Types of quadrilaterals

» Some special parallelograms

of Kite.
= Making a list for quadrilaterals
» Lab Activity
To prove angle sum property of a quadrilateral
Lab Activity
= To prove exterior angle property of any polygon.

Reference book




July
Chapter 4 (Practical Geometry)
» Construction of quadrilaterals
» Some special cases of quadrilateral

Chapter 5 (Data Handling)
» Organizing data
» Grouping data
» Circle graph or Pie-chart
» Chance and Probability

Chapter 6 (Squares and Square Roots)
» Properties of square numbers
» Patterns
» Finding the square of a number
» Pythagorean triplet
» Finding square roots by
o prime factorization
o division method
» Square roots of decimal
» Estimating square root

» Constructing a Quadrilateral:

e when four sides and one diagonal are given.

e when three sides and two diagonal are given.

e when two adjacent sides and three angles are
given.

e when three sides and two included angles are
given.

e when other special properties are known.

Introduction to graphs
Reading a bar graph

Pie chart

Introduction to probability

» Lab Activity

Collect the data and prepare a bar graph, histogram and
pie chart of the data collected

» Lab Activity

To verify identity (a + b)? and (a-b)? through activity.

>
>

>

>

Worksheet
Exploring
geometrical
shapes and
understanding
hidden
structures with
real life
examples.

quiz on
probability

Topic wise
Worksheet
Class test

NCERT
Textbook
Exercise
Assignme

nt

Assignment
R.D Sharma
Reference book

KeyTerms
NCERT
Textbook
Exercise
Assignme

nt

R.D Sharma
Reference book

KeyTerms
NCERT
Textbook
Exercise
Assignment
R.D Sharma
Reference book




Month Project/Activity Mental Maths | Written Work

Content/Theme

August » Worksheet » Key Terms

Chapter 7 (Cubes and Cube Roots) = QOral test on estimating the cube » NCERT Textbook
» Cubes roots. Exercise

» Cube Roots

Chapter 8 (Comparing Quantities)

» Compound Interest
» Rate compounded annually or half yearly
» Applications of Compound Interest

= To collect the rate of interest of
various banks on different types of
accounts

» Worksheet
> Discussion on
taxes levied
on different

objects.

» Assignment
» R.D Sharma
Reference book

» Key Terms

» NCERT Textbook
Exercise

» Assignment

» R.D Sharma
Reference book

September
Chapter 8 (Comparing Quantities)
» Increase or decrease percent
» Discounts
» Profit and Loss
» Sales Tax/VAT/ GST

Chapter 12 (Exponents and Power)
» Powers with negative exponents
» Laws of exponents
» Use of exponents to express small numbers in
standard form

HALF YEARLY EXAMINATION (1, 2,3,4,5,6,7,8 - half)

e To collect GST rates on any 10
products.

Activity on:

e Making a list of very small and
very large numbers from the facts
available and convert them in
Standard form. ( Microorganisms
and Planets)

» Worksheet

> Worksheet
Class test

» Key Terms

» NCERT Textbook
Exercise

» Assignment

» R.D Sharma
Reference book

» Key Terms

» NCERT
Textbook
Exercise

» Assignment

» R.D Sharma
Reference book




Month
Content/Theme

Project/Activity

Mental Maths

Written Work

October
Chapter 15 (Introduction to Graphs)

» Linear graphs
» Applications of graphs

Chapter 9 (Algebraic Expressions and Identities)

» Expressions

» Lab Activity
= Draw a line graph of
any real situation
problem.

Presentation on :

» Worksheet

YV V

NCERT Textbook Exercise
Assignment
R.D Sharma Reference book

. ) > Key Terms

» Terms, factors and coefficients * (atb) » NCERT Textbook Exercise
» Monomials, binomials and polynomials. = a’-b’ > Assignment
» Like and unlike terms _ . > R.D Sharma Reference book
» Addition and subtraction of Algebraic Expressions
» Multiplication of Algebraic expressions
» Multiplying a monomial by a monomial
» Multiplying a monomial by a polynomial
» Multiplying a polynomial by a polynomial
» Standard Identities

Month Project/Activity Mental Maths Written Work

Content/Theme




ovember » Activity on:
Chapter 11(Mensuration) = Surface area of Rectangular solids » Key Terms
» Area of trapezium = Application of Mensuration -Cylinder |» Worksheet » NCERT Textbook
» Area of general quadrilateral = To verify the formula for volume and Discussion on Exercise
» Area of a polygon surface area of cylinder, cube various solid | » Assignment
> Solid shapes cuboids through activity. shapes inthe | R.D Sharma
> Surface area of cube, cuboids and cylinders = To verify the formula for surface area surrounding Reference book
» Volume of cube, cuboids and cylinder of Trapezium through activity and counting
» Volume and Capacity the number of
faces.
b b PERIODIC TEST -2
eeember -half,9,12,1
Ch;lp]t)gr 13 IgDirect. and Inverse Proportion) (8-half.9,12, 5)> Worksheet > Key Terms
irect Froportion » Recognizing |» NCERT Textbook
> Inverse Proportion direct and Exercise
inverse » Assignment
proportion
based on real
life examples.
Chapter 14. (Fgctorisation) » Key Terms
> Factoqsa‘qon by common factors » Worksheet » NCERT Textbook
> Factoqsa‘qon by. regrouping terms Exercise
» Factorisation using identities. > Assignment

» Division of polynomials




Month Project/Activity Mental Maths Written Work
Content/T
heme
January » To identify factors of a number from a
Chapter 14 (Factorisation) collection of numbers. > Key Terms
» Factorisation using identities. Worksheet > NCERT Textbook
» Division of polynomials Exe'rmse
» Assignment
» R.D Sharma
Reference book
Chapter 16 (Playing with Numbers) Worksheet > Key Terms
> Letters for digits » NCERT Textbook
> Tests of divisibility Exercise
» Assignment
Chapter 10 (Visualizing Solid Shape) > Activity based on :
» Views of 3 D shapes Worksheet

» Mapping space around us
» Faces, Edges and Vertices
» Euler’s Formula

= Visualizing solid shapes

= [ntroduction to a prism

= [ntroduction to a pyramid

= To make the nets of 3Dshapes.

= To draw a map of the route from house to

school showing different landmarks.

Observation of
different things in the
surrounding and
discussing their various
views.

» Key Terms

» NCERT Textbook
Exercise

» Assignment

» R.D Sharma
Reference book

February

REVISION FOR ANNUAL EXAMINATION

March

ANNUAL EXAMINATION




Curriculum Plan of Science (Session: 2025-26)

Book prescribed: NCERT

Science

Month Project/Activity Oral Work Written Work
Content/Theme
April .
Chapter 8 (Cell Structure and Functions) > . Video _ > Oral > Kevierms

» Discovery of thecell e Cell structure and function Questioni > Y :

> The cell e Difference between plant cell and ng > Eg}g{u;stlons_

> Organisms show variety in cell number, animalcell > NCERT ; exereise

. > Activit » ScienceExemplar
shape and size ctvity Exemplar > Assi ;
» Cell structure and function e Temporary/Permane Discussion ssighments
: » Diagrams ofOnion peel cells,
» Parts of thecell nt slidesof )
. ) . . cheek cells, animal vs.
» Comparison of plant and animalcells Microorganisms
. . plantcell
e Temporary slide of onion/human
cheekcells
Chapter 4 (Materials: Metals and Non- » Video > Kevterms
Metals) e Physical properties of Metal » Oral Y .
. . : » KeyQuestions
» Physical properties of metals and non- metals andNonmetals. Question » NCERTexercise
» Chemical properties of metals and non- e Displacementreactions ing .
p > ScienceExemplar
metals >  Activit » NCERT .
y > Assignments
> Uses of metals andnon-metals e To check the electrical Exempl
conductivityof Materials ar
e Burning of Sulphurpowder Discuss
ion

e Reaction of metals and nonmetals
withacids




Chapter 11 (Force and Pressure) > Video » Oral » Keyterms
» Force-a push or apull e Forces are due to Question » KeyQuestions
» Forces are due to aninteraction interaction ing » NCERTexercise
» Exploringforces e Contact and Non-contact forces » NCERT ScienceExemplar
» A force can change the state ofmotion Exempl
ar
Discuss
ion
Month Project/Activity Oral Work Written Work
Content/Theme
June PERIODIC TEST -1
Chapter 9 (Reproduction in Animals) > ‘:“11\?[01 Femal ducti ¢ » gflilstionin i Ezyggensstions
» Modes of reproduction .a e ema‘ ¢ reproductive system g Y .
> . ° Blnary fission » NCERT » NCERTexercise
Sexual reproduction i Exemplar » ScienceExemplar
> Asexual reproduction * Budding . xemp?e > Ass p
e Metamorphosis Discussion < D‘ss1gnmentt§
> Activity lagrams o
e To observe the slide of Binary fission inAmoeba Male/(f er?ale .
reproductive system,
human sperm, ovum,
fertilization, binary
fission in amoeba,
budding inHydra
Chapter 10 (Reaching the age of > Video T o ioni Z Rovems
Adolescence) e Endocrine glands hormone and function uestoning eyQues tons
. . . . .. » NCERT » NCERTexercise
(Subject Enrichment-seminar) e Sex determination in the unborn baby Exemplar > ScienceExemplar
» Adolescence and puberty > Activity Discugsion >  Assionments P
» Changes atpuberty e Calculation of fullheight > Diaggrams of sex




VVVY VYV

Secondary sexualcharacters

Role of hormones in
initiatingreproductive function
Reproductive phase of life inhumans
How is the sex of the babydetermined?
Hormones other than sexhormones
Role of hormones in completing the
lifehistory of insects andfrogs
Reproductive health

Chapter 12 (Friction)

VVVVYY

Force of friction

Factors affectingfriction
Friction: a necessaryevil
Increasing and reducingfriction
Wheels reducefriction
Fluidfriction

Chapter 5 (Coal and Petroleum)

>
>
>
>

Coal

Petroleum

Naturalgas

Some natural resources arelimited

o Collect newspapercuttings and information
from magazines aboutHIV
e /AIDS.

» Video
e Friction: A necessaryEvil
e FluidFriction

> Activity

'Wheel reducesfriction

» Video
e Exhaustible and inexhaustible naturalresources
e Refining ofpetroleum
> Activity
e Get an outline map of India. Mark the places in
the map where coal, petroleum and natural gas
arefound.

Oral
Questioning
NCERT
Exemplar
Discussion

Oral
Questioning
NCERT
Exemplar
Discussion

YV VY

>

VVVYYVYYVY

determination of
unborn child, position
of endocrine glands in
the humanbody

Keyterms
KeyQuestions
NCERTexercise
ScienceExemplar

ssignments

Keyterms
KeyQuestions
NCERTexercise
ScienceExemplar
Assignments

Diagram of Refiningof
Petroleum




July & August

Chapter 2 (Micro-Organisms Friend and
Foe)

Microorganisms

Where do microorganismslive?
Microorganisms andus
Harmfulmicroorganisms
Foodpreservation

Nitrogenfixation

Nitrogencycle

VVVVVVY

Chapter
16(Light)
What makes thingsvisible
Laws ofreflection
Regular and diffusedreflection
Reflected light can be reflectedagain
Multipleimages
Sunlight: white orcoloured
What is inside oureyes?
Care of theeyes
Visually challenged persons can
read and write
» What is the braillesystem?
Chapter 6 (Combustion and Flame)
» What isfuel?
» Fuelefficiency

VVVVVVVVYY

» Video
e Microorganisms Friend andFoe
e Nitrogen cycle

> Activity
e Observation of pond water for presence
ofmicroorganism.

e Hands on activity todemonstrate
fermentation of Sugar solution and Dough
by usingyeast.

e To show temporary/permanent slides of
variousmicroorganisms.

» Video
o Reflection ofLight
e HumanEye
e Care of eyes
> Activity
e Multiple reflection usingmirror
o Kaleidoscope construction andworking

> Activity
e Experiment to show that air is essentialfor
burning
e Make a model of fire extinguisher

» Oral
Questioning
» NCERT

Exemplar
Discussion

» Oral
Questioning

» NCERT
Exemplar
Discussion

» NCERT
Exemplar
Discussion

YVYVYYVY

YVVVYY

Keyterms
KeyQuestions
NCERTexercise
ScienceExemplar
Assignments
Diagrams
ofMicroorganisms,
Nitrogencycle

Keyterms
KeyQuestions
NCERTexercise
ScienceExemplar
Assignments
Diagrams of Laws of
Reflection, HumanEye

Assignments
Diagram of different
zones of candle flame




Audible and inaudiblesounds
Noise and music

e Sounds Needs a Medium for propagation

box, HumanEar

Month Project/Activity Oral Work Written Work
Content/Theme
August & September e Electroplating » Oral » Keyterms
Chapter 14 (Chemical effects of electric e Testing conduction of electricityin Questioning » KeyQuestions
current) lemon juice orvinegar » NCERT » NCERTexercise
> Do liquids conductelectricity? e A simple circuit showingelectroplating Exemplar ScienceExemplar
» Chemical effects of electriccurrent Discussion » Assignments
» Electroplating » Diagram
ofElectroplating
Chapter 13 (Sound)
» Sound is produced by a vibratingbody > Video » Oral » Keyterms
> Sound produced byhumans ¢ HumanEar Questionin > KeyQuestions
» Sound needs a medium forpropagation ¢ Sound Needs a Medium for g » NCERTexercise
» We hear sound through our ears Propagation > NCERT » ScienceExemplar
» Amplitude, time period and frequency of | > Activity Exemplar » Assignments
avibration e Jaltrang Discussion » Diagrams ofvoice
>
>
>

Noise pollution




Month Project/Activity Oral Work Written Work
Content/Theme
HALF YEARLY EXAMINATION

October & November -
Chapter 1 (Crop Production and Management) > Video _ > Oral > Keyterms

> Agriculturalpractices e Kharif and Rabicrops Questioning | > KeyQuestlong

» Basic practices of crop production * Methods of irrigation » NCERT > NCERTexercise

» Preparation ofsoil > Activity E)Femplgr > SmepceExemplar

> Sowing e Collect new agricultural Discussion | » Assignments

» Adding manure andfertilizer machine pictures and > Diagrams of Modern and

> Irrigation paste them in your traditional methods of

» Protection fromweeds notebook with their 1rrigation

» Harvesting,Storage names and uses.

» Food from animals e Hands on activity to

demonstrate Selection
ofSeeds
> Video » Oral » Keyterms

Chapter 3 (Synthetic fibre and Plastics) e Synthetic fibres and uses. Question > KeyQuestions

> What are syntheticfibres? > Activity ng > NCERT exercise

» Types of syntheticfibres » Debate on the topic ‘My » NCERT > SmgnceExemplar

> Characteristics of syntheticfibres fabric isSuperior’ Exemplar > Assignments

> Plastics Discussion | » Diagrams ofMonomers

» Plastics as materials ofchoice andPolymers

Plastics and theenvironment




Month Project/Activity Oral Work Written Work
Content/Theme
December » Video » Oral » Keyterms
Chapter 15 (Some Natural Phenomenon) e Charging byRubbing Questioning » KeyQuestions

» Lightning e The Story ofLightning » NCERT » NCERTexercise

» Charging byrubbing e Earthquake Exemplar » ScienceExemplar

» Types of charges and their > Activity Discussion » Assignments

interaction, Transfer ofcharge e Types of Charges and theirInteraction > Diagrams of Electroscope,

» The story oflightning e Working ofelectroscope Lightning conductors,

» Lightningsafety Structure of the

» Earthquakes Earth,Seismograph
January » Video » Oral » Keyterms
(Subject Enrichment) e Deforestation and itsCauses Questionin > KeyQuestions
Speaking Skill e Flora andFauna g » NCERTexercise
Chapter 7 (Conservation of Plants > Activity » NCERT » ScienceExemplar
and Animals) e Tree plantation and itsmaintenance Exemplar > Assignments

» Deforestation and itscauses Discussio » Diagrams of

» Consequences ofdeforestation n Endangeredspecies.

» Conservation of forest and wildlife

» Biosphere reserve

» Flora and fauna

» Endemic species

» Wildlife sanctuary

» Nationalpark

» Red databook

» Migration

» Recycling ofpaper

>

Reforestation




Chapteri8PollutionofAirandWater
Airpollution
Howdoesairgetpolluted?
Casestudy-TheTajMahal
GreenhouseEffect,whatcanbe
done?

Waterpollution
Howdoeswatergetpolluted?
Whatispotablewaterandhowis
waterpurified?

» What can be done?

YV VY

YV V

> Video » Oral » Keyterms
e Airpollution Questionin » KeyQuestions
e WaterPollution g » NCERTexercise
e Green HouseEffect » NCERT » ScienceExemplar
> Activity Exemplar Assignments
Comparisonofdifferentsampleof Discussio
water(smell,acidity,andcolor) n

February

REVISION FOR ANNUAL EXAMINATION

March

ANNUAL EXAMINATION




Curriculum Plan of English
(Session: 2025-26)

Prescribed books- Honey Dew

Month Vocabulary/ Grammar Listening Skills Speaking Skills / Reading Skills | Writing
Content/Theme Art Integration Skills
4 April Verbs Gerunds and participles- | = Dictation » Presenting a story |= Reading for |= Notice
e The best Christmas present in » Giving directions appreciation writing
the world » Listening Text *Enactment of (poem) » Diary
e The Tsunami- ( only for speaking | The best Christmas |« Reading for
skills) Subject-verb agreement-3pds present in the world detail
e Poem-Geography lesson o Inter-disciplinary
Tenses Linkage
o Preparednes
s during a
calamity

o Core Life skills
o Inter personal
relationship

e Core Values Concern
Self
confidence,
Humility and
Politeness

I May PERIODIC TEST —
1




Month Vocabulary/ Grammar | Listening Skills | Speaking Skills / Reading Skills | Writing
Content/Theme Art Integration Skills
< June Tenses ( Past and future) — | = Dictation = Debate/ Role Wave » Message
*BipinChaudhary’s » Audio clip: Enactment reading of
lapse of memory ‘The Tiger’ by |e Inter-disciplinary thepoem
];‘:lfl :llill(: poem- Last ) ) ] WilliamBlake | Linkage Reading for
g /Active Passive Voice Human psychology detail
e Core Life skills
o Inter personal
relationship
e Core Values Concern
Selflessness
Politeness
1 July = Articles and *Dictation * PoemRecitation Reading for |= Article
*The Summit within Determiners »ListeningText |= Class Discussion appreciation writing
of the book they (poem)
read » Reading for
e Inter-disciplinary detail
*And and the Cricket Linkage

o Scientific
significance of
mountains

e Core Life skills
o Inter personal
relationship
e Core Values Concern
Self confidence,
helpful nature
,hard work and
perseverance




Month Vocabulary/ Grammar Listening Skills Speaking Skills / Reading Skills | Writing
Content/Theme Art Integration Skills
4 August Sentences and phrases = Dictation = Talk Time- = Poem = Letter
*This is Jody’s Fawn = Listening text: Sharing personal recitation writing- to
*The duck and the kangaroo. |[Nouns and pronouns Laughter theBest | experience * Reading for the editor’
Medicine e Inter-disciplinary detail placing an
Modals = Audio clip: Linkage order and
How laughing o Scientific complaint
affects our health significance of letter

Animals
e Core Life skills
o Inter dependence
e Core Values
Concern
Friendship,
moral
obligation

N5 September
Recap of all the chapters

HALF YEARLY EXAMINATION

+ Book 3:Grammar
Adjectives and Degrees of

comparision

Adverbs and degrees of
comparison -

= Dictation

» ListeningText

» Talking about
Interests and
Hobbies

= Revision of
Novel they
read

= Dramatised
Reading

(Play)

= Revision of
letter




Month
Content/Theme

Vocabulary/ Grammar

Listening Skills

Speaking Skills /
Art Integration

Reading Skills

Writing
Skills

4 October
When I set out ford Lyonnesse

conjunctions

Prepositions

» Dictation
» Audio clip:

Commonly
Mispronounced
Words

= Group-Discussion/
Conducting an
Interview or
Celebritylnterview
e Inter-disciplinary
Linkage
o Scientific
significance of
myths
e Core Life skills
o Inter personal
relationship
e Core Values Concern
Self confidence,
Humility and
Politeness

» Reading for
appreciation
(poem)

» Reading for
detail

*Descriptive
paragraph

4 November
Glimpses of the past

+ Book 3: CornerStone
(Grammar)
» Direct and
IndirectSpeech

= A/V-clip:

Biography of
Stephen
Hawking

= Speech
= Discussion
of the book
they read
e Inter-disciplinary
Linkage
o significance of
places and history

= Extended
Reading

Extra
writing
practice




Month Vocabulary/ Grammar Listening Skills | Speaking Skills / Reading Writing
Content/Theme Art Integration Skills Skills
4 December

A visit to cambridge

PERIODIC TEST -2

» Direct and
IndirectSpeech

= Dictation

» Talk time- Your
Dream City /
Conversation —
offering
condolences

o Inter-disciplinary
Linkage

¢ Scientific significance
of disabilities

e Core Life skills

o Inter personal

» Reading for
detail

» Story writing

relationship
¢ Core Values Concern
Self confidence,
courage,determination
4 January % Book 3:Grammar » Dictation » Roleplay * Dramatised |= Picture
A Short Mansoon Diary » Audio —clip: |= Discussion ofNovel reading Composition
British and o Lesson 6 (play) = Newspaper
The Great stone face-part 1&2 American e Inter-disciplinary Report
Spellings Linkage

» ListeningText

o Scientific
significance of
weather

e Core Values Concern
Self confidence,
hope and faith

»LFebruary

REVISION FOR ANNUAL EXAMINATION




JdMarch

ANNUAL EXAMINATION
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Curriculum Plan of Social Science

(Session: 2025-26)

Books Prescribed: 1. Our Pasts—III 2. Social and Political Life— III 3. Resources andDevelopment
Month Project/ Activity Oral Work Written Work
Content/Theme
April » Activity » Oral questioning » Key terms
4 Our Pasts-III » Interview of Family member | » Discussion-How » Key questions
* Chapter 1 - How When & Where (by students) agriculture changed » Flow Chart-Periodization
1. How important are Dates? after Independence? | > NCERT Exercise
2. How do We Know? » Assignment
» Worksheet
<4 Social and PoliticalLife-III » Video » Oral questioning
= Chapter 1 - The IndianConstitution = Making of Constitution » Discussion-Minority | » Key terms
1. Why Does a Country needa = Key Features of Constitution groups in India » Key questions
Constitution? » Activity » Flow Chart-Features of
2. The Indian Constitution: = Reading the Preamble Constitution
Key features » NCERT Exercise
» Assignment

= Chapter 2 UnderstandingSecularism
1. What isSecularism?
2. Why is it Important toSeparate
Religion from the State?
3. What is IndianSecularism?

> Video
= Secularism
»  Activity
= Compare-Annual calendar of
the school with a Normal
calendar

» Oral questioning

» Discussion-Schools
should not promote
any religion

» India-Political Map

» Key terms

» Key questions

» NCERT Exercise
» Assignment




Month Project/ Activity Oral Work Written Work
Content/Theme
April » Video » Oral questioning » Key terms
1 Resources andDevelopment = Resource » Discussion on Conserving | » Key questions
= Chapter 1Resources * Types of Resources. resources » NCERTExercise
1. Types of Resources » Assignment
2. Conserving Resources » Flow Chart- Types
of Resources
= Chapter 2 Land, Soil, WaterNatural
Vegetation and WildlifeResources » Video » Oral questioning > Key terms
1. Land, Land Use * Water Scarcity and » Discussion- Forestfire. » Key questions
2. Conservation of Land Resource conservation methods » NCERT Exercise
3. Soil,Factors of soil Formation > Activity > Assignment
4. Degradation of Soil = Collect information-
and Conservation Land use pattern
Measures
5. Water, Problem of water availability
6. Conservation of Water Resources
7. Natural Vegetation and Wildlife
8. Distribution & conservation of
Natural Vegetation andWildlife
June PERIODIC TEST - 1
4 Social and Political Life-III » Video » Oralquestioning » Keyterms
= Chapter 3 Why Do We Need * Role ofParliament » Discussion-MPs inyour » Keyquestions
Parliament » Activity state. » NCERTExercise
1. Why should PeopleDecide? = Know more about » Assignment
2. People and theirRepresentatives your state-
3. TheRoleoftheParliament Parliamentary
4 constituencies

. Who are thePeople in Parliament




Month Project/ Activity Oral Work Written Work
Content/Theme
July » Video » Oral questioning » Keyterms
4 Our Pasts-III * Tipu Sultan and East India » Discussion-Battle |» Keyquestions
* Chapter 2 From Trade toTerritory Company of Plassey » NCERTEzxercise
1. East India Company ComesEast. > Activity > Assignment
2. Company RuleExpands = Collection of pictures and
3. Setting up a NewAdministration stories- Rulers of Princelystates
= Chapter 3 Ruling the Country side » Video » Oral questioning » Key terms
1. The Company Becomes the Diwan * Indigo planters » Discussion-Life of | » Key questions
2. Crops for Europe » Activity the workers » NCERT Exercise
3. The “Blue Rebellion” and After = Report- Rural areas in company » Assignment
rule
<4 Social and PoliticalLife-III
= Chapter 4 UnderstandingLaws » Video » Oral questioning » Key terms
1. Do Laws Apply toAll? = Feminist movements in India » Discussion- » Key questions
2. How Do New Laws Come About? > Activity Domestic Violence | » NCERT Exercise
3. Unpopular and ControversialLaws = Essay- Feminist movement Act2005 » Assignment
4 Resources and Development
» Chapter 3 Minerals and Power Resources | > Video » Oral questioning | > Key terms
1. Types of Minerals = Conventional & Non- » Discussion-Geo » Key questions
2. Distribution of Minerals conventional resources thermal energy, » NCERT Exercise
3. Distribution in India » Activity Tidal energy » Assignment
4. Power Resources = Poster making — Energy » Map- Distribution of
5.

Non-conventional Sources of Energy.

conservation measures

Iron, Bauxite,
Manganese and mica
Flow Chart-
Conventional and
Non-conventional
Resources

A\




Month Project/ Activity Oral Work Written Work
Content/Theme
August » Video » Oralquestioning » Keyterms
4 Our Pasts-III = Tribal groups in India » Discussion-Coal » Keyquestions
= Chapter 4 Tribal Dikus & The Vision of a » Activity miners ofBihar » NCERTExercise
GoldenAge = Story writing-Tribalheroes » Assignment
1. How did Tribal GroupsLive?
2. How did Colonial Rule Affect TribalLives?
3. A closerlook
= Chapter 5 When People Rebel 1857 andAfter | > Video » Oralquestioning > Keyterms
1. Policies and thePeople = Revolt of1857 » Discussion-Revolt | > Keyquestions
2. Through the Eyes of thePeople » Activity 1857 » NCERTExercise
3. A Mutiny Becomes a Popularrebellion = Quiz- Revolt of1857 » Assignment
4. The Company FightsBack » Map
5. Aftermath
4 Social and PoliticalLife-ITI
= Chapter 5 Judiciary > Video » Oral questioning » Key terms
1. What is the Role of the Judiciary? = Judiciary in India » Discussion- » Key questions
2. What is an Independent Judiciary? > Activity Independent » NCERT Exercise
3. What is the Structure of Courts in India? * Story writing- Judiciary. » Assignment
4. What are the different Branches of the ‘Justice delayed is the justice » Flow chart —

Legal System?

5. Does Everyone Have Access to the Courts?

4 Our Pasts-11I
= Chapter 6 Colonization and The City

1. What Happened to Cities UnderColonial
Rule?

2. The Making of New Delhi

3. Inside the Old City

denied.’

» Video
= Making of New Delhi
» Activity
= Comparative study-Old Delhi
and New Delhi

» Oralquestioning
» Discussion-Making
of NewDelhi

Courts in India

Key terms

Key questions
NCERT Exercise
Assignment

Map

VVVVYYVY




Month Project/ Activity Oral Work Written Work
Content/Theme
September
L Social and Political Life-II HALF YEARLY EXAMINATION
= Chapter 6 Understanding Our Criminal Justice Video » Oral questioning |» Key terms
System = Criminal Justice System » Discussion-FIR | > Key questions
1. What is the Role of the Police in Investigating Activity » NCERT Exercise
a Crime? = Role play-Functions of > Assignment
2. What is the Role of the Public Prosecutor? criminal justice system
3. What is the Role of the Judge?
4. What is a Fair Trial?
October Video Oralquestioning | » Keyterms
4 Our Pasts-IIT = Tata Iron and SteelPlant Discussion-Tata |» Keyquestions
= Chapter 7 Weavers, Iron Smelters and Activity Iron andSteel. » NCERTExercise
Factory Owners = Essay writing -Craftsmen » Assignment
1. Indian Textiles and the WorldMarket Community inIndia » Map
2. The sword of Tipu Sultan and WootzSteel
<4 Social and Political Life-III
= Chapter 7 Understanding Marginalization Video Oral questioning | > Keyterms
1. Who are Adivasis? * Minorities inIndia Discussion- Low |» Keyquestions
2. Adivasis andStereotyping Activity literacy rate in » NCERTEXxercise
3. Adivasis andDevelopment = Story completion - Soma minorities » Assignment
4. Minorities andMarginalization andHelen
1 Resources andDevelopment
» Chapter 4Agriculture Video Oralquestioning | » Keyterms
1. Farm system = Farming inIndia Discussion- » Keyquestions
2. Types of Farming Activity Indianfarmers » NCERTExercise
3. Agriculturaldevelopment = (Collection of pictures-USA » Assignment
Farmers. » Flow Chart-
Primitive and
Subsistence

Farming




Month Project/ Activity Oral Work Written Work
Content/Theme
November » Video » Oralquestioning » Keyterms
4 Our Pasts-III * Macaulay’s education » Discussion- » Keyquestions
* Chapter 8 Civilizing the "Native' Educating System WoodsDespatch » NCERT
The Nation » Activity Exercise
1. How the British sawEducation = Debate- EducationSystem » Assignment
2. What Happened to the LocalSchools?
3. The Agenda for a NationalEducation
= Chapter 9 Women, Caste and Reform. > Video Oralquestioning > Keyterms
1. Working towardsChange * Gender and Caste reforms in Discussion-Caste | » Keyquestions
2. Caste and Social Reform India discrimination » NCERT
3. The Non-Brahman movement » Activity Exercise
* Quiz- Caste reforms inIndia » Assignment
= Chapter 10 The Changing World of Visual Arts | > Video Oralquestioning > Keyterms
1. New forms of Imperial Art = History of IndianArt Discussion- » Keyquestions
2. What happened to the CourtArtists? > Activity Photographyin » NCERT
3. The New Popular IndianArt * Collecting Information on India Exercise
4. The search for a National Art different art forms inIndia. » Assignment
4 Social and Political Life-III
= Chapter 8 Confronting Marginalization » Video Oralquestioning > Keyterms
1. Invoking Fundamental Rights = SC & ST Act1989 Discussion-1989 > Keyquestions
Laws for the Marginalized > Activity Act. » NCERT
= Tabular presentation on Exercise

2.
3. Protecting the Rights of Dalit’s andAdivasis
4. Adivasi Demands and the 1989Act

Socio-economic condition of
Marginalizedcommunity

» Assignment




Month Project/ Activity Oral Work Written Work
Content/Theme
November » Video » Oral » Keyterms
4 Our Pasts-III = History of IndianArt questioning » Keyquestions
= Chapter 10 The Changing World of VisualArts » Activity > Discussion- > NCERT
1. New forms of Imperial Art = Collecting Information on Photography Exercise
2. What happened to the CourtArtists? different art forms inIndia. inIndia » Assignment

3. The New Popular IndianArt
4. The search for a National Art

December
4 Our Pasts-II1

PERIODIC TEST -2

= Chapter 11 The Making of The NationalMovement » Video » Oral » Keyterms
1. The Emergence ofNationalism = Dandi March Quit India questioning > Keyquestions
2. The Growth of MassNationalism Movement » Discussion- » NCERT
3. The March toDandi > Activity National Exercise
4. Quit India andLater = Essay- Leaders of National Movementsin | > Assignment
Movement India » Map
<4 Social and PoliticalLife-III
» Chapter 9 PublicFacilities » Video » Oral » Keyterms
1. Water and the People of Chennai = Public Facilities inIndia questioning » Keyquestions
2. Water as part of the Fundamental Right toLife > Activity » Discussion- » NCERT
3. PublicFacilities = Report- Public Transport Public Exercise
4. The Government’sRole System inIndia Facilities » Assignment
5. Water Supply to Chennai: Is it Available toAll?
6. In Search ofAlternatives
January » Video » Oral » Keyquestions
4 Our Pasts-III = Division of India on questioning » Keyterms
= Chapter 12 India afterIndependence LinguisticPrinciples » NCERT
1. A new and DividedNation Exercise

2. A Constitution isWritten
3. How were States to be formed?




Month Project/ Activity Oral Work Written Work
Content/Theme
January > Activity » Discussion- » Assignment

4 Our Pasts-11I
= Chapter 12 India afterIndependence
4. Planning for Development
5. The Nation, Sixty year son

1 Social and PoliticalLife-ITI
= Chapter 10 Law and SocialJustice
1. Bhopal GasTragedy
2. What is a Worker’sWorth
3. Enforcement of SafetyLaws
4. New laws to Protect theEnvironment

1 Resources andDevelopment
= Chapter S Industries
1. Classification ofIndustries

2. Factors affecting Location ofIndustries
3. IndustrialSystem

4. IndustrialRegions

5. Distributions of MajorIndustries

6. Cotton Textile Industry

7. Information Technology(IT)

Distribution and Density ofPopulation
Factors Affecting Distribution of
Population

3. GeographicalFactors

4. Social, Cultural and EconomicFactors

= Chapter 6 HumanResources
1
2

= Debate- Division of states on
Linguistic groups

» Video
= Bhopal GasTragedy
» Activity
= Report- Bhopal GasTragedy

» Video
= Jamshedpur Iron and Steelplant
= Information Technologyin
India
> Activity
= Report- IT hub ofIndia
(Bengaluru)

» Video
= Population change andfactors
affecting inIndia

English asa
language

» Oral
questioning

» Discussion-
Environmental
degradation

» Oral
questioning

» Discussion-
Industrial

Development in
India

» Oral
questioning

Keyterms
Keyquestions
NCERTExercise
Assignment

YV VY

Keyterms
Keyquestions
NCERTExercise
Assignment
Map- IT and Iron
and Steelindustry

YVVVYY

Keyterms
Keyquestions
NCERTExercise
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FEBRUARY

REVISION FOR ANNUAL EXAMINATION

MARCH

ANNUAL EXAMINATION




ANNUAL CURRICULUM PLAN

CLASS

-Vl

(Session: 2025-26)

Computer Science

Examination Schedule & Syllabus
(Session: 2022-2023)

Computer Term-1 Term-2
Science
7 September 2022 2 March 2023
4 MS Access 4 HTML

4 Computer Networking
4 More on Internet

4 Adobe Flash
4 Computer Ethics, Crime &
Security




Curriculum Plan of Computer Science
(Session: 2025-26)

Book Prescribed: Magic With computers

Month Theory Activities Practical /Project
April -
Learn To Use > Introduction > Discussion of data, records, > Create And Set The
Access 2007 » Database database of student & Writing Field Of
» Rdbms Student database - 15 records e  Student Data
> Database Object > Same way Employee data and e Teachers Data
e Table teacher's data e Employees Data
e Form » Define database and rdbms Manually
e Report » Define database object table form
e Query report and query Lab
» Starting Ms Access » Define ms access > Create And Set The
> Creating A Database (Blank By A Template) » Create database in ms access Field Of
» Creating Table (blank) e Student Data
» Creating Table Using Design View > Create tables in database using * Teachers Data
» Viewing Table In Database design view data sheet view e Employees Data in
» Switching View > View and describe table structure MS Access
»  Primary Key » Define primary key
» Relationship » Switch between different views
» Add, update, delete, records in
table
» Create relationship in tables
May Vacation




June
Queries, Forms &

Report In Ms-
Access 2007

Introduction

Queries In Ms Access

e Creating Different Queries
Forms In Ms Access

e Creating AForm

Reports In Ms Access

e Creating A Report

Define Form Report And Query
Create Form And Update Record
Create Report And Adjust Field
Size For Printing

Create Query And Run

Lab
Create And Set The

Field Of

e  Student Data

e Teachers Data
Employees Data in
MS Access

And create query,

report and form for the

same in MS ACCESS




Month Theory Activities Practical /Project
July
Introduction » Introduction » Define computer network » Visit To Computer Lab And
To Coml?“tef » Computer Network » List the benefits of a network Understand LAN
Networking .

» Creating Computer Network » Create computer network » Make Chart Of Network LAN, MAN,

> Network Benefits > list hardware requirement to WAN, CAN

» Network Hardware establish a computer network

» Types Of Network PAN ,LAN, WAN And MAN » differentiate between various type

» Nature Of Computer Network of network and their nature

> Network Technologies > Define network topologies list

» Star Topology ,Ring Topology, Bus Topology advantage and disadvantage of

> Protocols various topologies

» Define protocol

August

More On Internet

A\

YV V V V

Introduction
E-Commerce

Advantage Of E-Commerce

E-Commerce Payment System
E- Commerce Sites And Ethics

How To Do Online Shopping
Online News

Video Conferencing

Newsgroups

Blogs

Social Networking

» Define commerce and the mode of
e-commerce

> ldentify the types of people
involved in e-commerce

» List the advantage of e-commerce

» Know e-commerce payment system

» Define ethics and sides of e-
commerce

» Online shopping

» View online news on toi

> Define video conferencing and
newsgroup

> Define blogs and list its advantages

» Social networking sites and its
advantages

» Collect Information About
e E Wallet,
e Blog,
e Digilocker




September Lab- Practical — Revision of all topics & Practical exam for Term-1
HALF YEARLY EXAMINATION- Written Exam
Month Theory Activities Practical /Project
October _
Introduction to | » Introduction of HTML > Understand the tools required to  [Lab
HTML » Features of HTML create web page » Create first web page in notepad

» Tools required to create a web page

» Terms in HTML

» Structure of an HTML Document

» Creating & saving HTML document with
text editor

» Viewing an HML document in web browser

e Text editor
e A Web Browser
e A web Server

» Terms in HTML
»HTML Tag-
¢ Empty- nonempty
e Attributes
e Values
e Nesting tags
e Special symbols
» Structure of HTML
» Basic syntax of HTML

» Creating HTML document in
text editor- Notepad

» Saving it as name.html

» Viewing the same in web
browser

and save as first.html
» View in browser

November
Creating
Webpage
using HTML

» Introduction
» Adding headers
» Adding paragraphs
» Adding line breaks
» Drawing horizontal line
e adding color , width to lines

» Create web page using HTML

» Add header, paragraph, line breaks

» Draw horizontal rules & add color
to the lines

» change font, font size, font color
and font style

» Formatting text

Lab
» Create an HTML document
e set background
e Header
o Title
» insert horizontal line and add color

Lab




» Marquee text

» Adding comments

» Setting background color

» Inserting images

» Setting image as a background
» Creating lists

» Creating Tables

» Inserting pictures, images

» Inserting Hyperlink

» Add Marque effect
» Add comment in HTML document
» Insert images
» Change the background
> Create tables
» Create Lists
e ordered list
e unordered list
e nested list
e Definition list
» Insert hyperlinks

» Create a HTML document

e Insert image

e Write text and insert marquee

e Make the list of shakes in
ordered list

e Make list of snacks in
Unordered list

e insert hyperlink of related
document

¢ Insert table with price list

December
Learn to use
Adobe
FlashCS3

introduction

Starting Adobe Flash CS3\
Creating new flash file
Components of the Flash Interface
Saving Flash file
Opening a Flash File
Exiting Flash

Flash Tools Panel
Using the Flash Tools
Line

Pencil

Rectangle tool
Brush tool

Paint Bucket tool
Eraser

Text

Selection tool

Free Transform

» Property inspector

» Grouping Objects

» Timeline Panel

e Frames

VVVVVVVYVYY

start Adobe Flash CS3

Create a Flash file

Identify and name the components

of Flash interface

Save, Open and exit Flash file

View the components of Tools

panel

Know the use of property Inspector

Use Various tools

Line

Pencil

Rectangle tool

Brush tool

Paint Bucket tool

Eraser

Text

Selection tool

Free Transform

» Group and ungroup objects

» Identify different components of
timeline panel

» Insert key frames/ frames

YVV VVYV

\ 274

Lab
» Draw the image in Flash and group
all the object as one.

» Open a Flash document and create
the symbol and make many
instances of it

Lab

» draw the ball with oval tool and
give effect to see bouncing ball

» Draw Caterpillar with oval shape
and make it move with animation
motion tween

» Make a fish and move it from left
to right on the stage using motion
tween animation

» Draw a circle and change to flower
using shape tween animation

» Show frame by frame animation to
make the text "Hello" appear
character by character.




e Layers
» Symbols
» Animating movie
e Motion Tween animation
e Shape Tween animation
e Frame by Frame animation

YV VYV

Delete frames

Define layer

Create symbol

Animate & test flash movie

e Motion Tween animation
e Shape Tween animation

e Frame by Frame animation

January
Computer
Ethics, Crime
and Security

» Introduction
» Computer ethics
Intellectual Property rights
Copyright
Software Piracy
Privacy
» Computer Crime
eHacking
ecracking
» Computer Security
» Last words

Define computer Ethics

List major ethical issues in
computer

Define Software piracy and its
types

Define and differentiate Hacker &
Cracker

List the various computer security
issues

Make the chart of Cyber security
guidelines

Make a chart of computer crime
and how to avoid

February

Lab Practice For HTML and Practical Annual Examination

Project - HTML -Create web pages of any three important organ of body with images

March

ANNUAL EXAMINATION- Written
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